TC-2048 W poszukiwaniu awarii

retro timex 2020-07-28, 23:07,

Wstępne pomiary napięcia na wyjściu zasilacza, rezystancji między 5V a masą oraz napięć po włączeniu zasilania nie sugerują niczego złego. Po uruchomieniu jednak widać tylko szary ekran i czarne paski. Wstępna diagnoza - RAM. Ale organoleptyczna analiza temperatury doprowadziła do oparzenia palca o procesor. Niby NMOS, ale po 30 sekundach nie ma prawa parzyć. 

Zrobiłem zatem zamówienie na procesor, układy logiczne, podstawki oraz RAM. Paczka przyszła, czas na plecionkę w dłoń i usuwamy CPU.

Zmiana na nowy CMOS od Ziloga poprawiła nieco sytuację, pasy poziome zmieniły się na pionowe. Napięcia ok, czas na oscyloskop. Zegar do CPU dochodzi, jest nieźle. Jakaś aktywność na liniach adresowych i danych również, ale nadal coś jest nie tak. Niektóre osiągają ledwo 2,5V. Trochę mało jak na TTL. Po kilku minutach testów… auć, teraz EPROM parzy.

Związek jego z CPU bliski, więc jako następny układ wyleciał z płyty a w jego miejscu pojawiła się podstawka z nowym układem. Po szybkim sprawdzeniu linii pod kątem zwarć coś nadal jest nie tak. Linia D4 do masy ma 10 Ohm. To nie jest normalne. Na linii D4 znajdują się 2 układy pamięci, 74LS244, 74LS245 oraz procesor i EPROM.

W poszukiwaniu zwarcia posłużyłem się założeniem, że im bliżej zwarcia tym rezystancja mniejsza. Usunąłem CPU i EPROM z podstawek, nastawiłem miernik na pomiar rezystancji na zakres Ohm, z dokładnością do 2 miejsc po przecinku.

Najniższe wskazanie, 10,48 Ohm było obok 74LS244, interfejsu Kempston. Wszędzie dalej było bliżej 11 lub powyżej. Wylutowałem element i rzeczywiście, diagnoza była trafna.

Weryfikacja układów 74LS244 oraz oryginalnej kości EPROM potwierdziły uszkodzenie linii D4 w obu elementach.

Po podłączeniu CPU i EPROM moim oczom ukazał się ekran powitalny. I wszystko byłoby super, tylko klawiatura nie działa…

Komentarze